• You are not logged in.
  • 1

Bug Report: Cannot change member's password

  • Started by siprof
  • 6 Replies
  • siprof
  • New Member
  • Reputation: 1
  • From: Indonesia
  • Registered: 19-09-2016
  • Posts: 6

Hello,

During testing, I did not input SMTP credentials.. However, I created a new member as part of testing. Because I did not input the SMTP credentials, I must change the password of new member in order to login as new member. The problem is I am unable to change the password as admin (Submit button did not work).

My server configuration: Debian 8, EasyEngine 3.7.4, nginx (I modified a little bit from EasyEngine's configuration), Let's Encrypt, PHP 7, MariaDB 10.



Oh, I have 2 more questions related to nginx. I follow your nginx configuration and found that:

1. Addons set as blocked, however this will make addons/extensions inaccessible as admin. Why?
2. Seo friendly url seems did not work

Here is my nginx configuration: http://pastebin.com/ePLYeQ5d

Offline
  • 0
  • Weksart
  • Styles Lead/Co-Manager
  • Reputation: 16
  • From: France
  • Registered: 22-04-2015
  • Posts: 49

Hi there and welcome!
Somebody will come to help you, keep update... smile

Offline
  • 0
  • Chris98
  • Project Manager
  • Reputation: 51
  • From: England, United Kingdom
  • Registered: 15-04-2015
  • Posts: 512

Hi siprof,

Welcome to the forum, and thanks for joining us. smile

The change password error is a known bug in this version, and is due to an incorrectly placed closing </form> tag. I am pleased to say it has been fixed in the next version, which we are adding the final styling alterations to now. I'm hoping it should be no longer than a week.

In regards to your questions on Nginx, I have forwarded this thread to vank1ta, who knows more about Nginx than me.

Kind regards,
Christopher Marshall
chris [at] get-aura [dot] org

Project Manager

Offline
  • 0
  • vank1ta
  • Development Lead/Co-Manager
  • Reputation: 4
  • Registered: 15-04-2015
  • Posts: 14

Hi siprof,

Did you follow my Nginx Tutorial?

  • The access to "addons|attachments|cache|lang|plugins" is denied as Nginx does not support .htaccess and that's the way we have it for Apache users so this is the correct way of doing this in Nginx.

  • About the SEO URLS please check if you have the correct dir - "rewrite ^(.*)$ /include/rewrite.php last;" correct.

Please let me know how you get on.

Thank you.

Offline
  • 0
  • siprof
  • New Member
  • Reputation: 1
  • From: Indonesia
  • Registered: 19-09-2016
  • Posts: 6

Hello,

Thanks Chris98! Glad to hear that smile

vank1ta, I follow your tutorial and apparently I need to change URL type in order to enable SEO friendly, silly me...

anyway about blocking addons on nginx, is that normal? so when I need to install new extension, I must edit my nginx configuration first?

Thank you

Offline
  • 0
  • vank1ta
  • Development Lead/Co-Manager
  • Reputation: 4
  • Registered: 15-04-2015
  • Posts: 14

Hi siprof,

I have updated Nginx Tutorial as addons folder got renamed a while ago to extensions. Please let me know if everything is working correctly now?

Thank you.

Offline
  • 0
  • siprof
  • New Member
  • Reputation: 1
  • From: Indonesia
  • Registered: 19-09-2016
  • Posts: 6

Hi vank1ta,

Ah yes, everything is good now.

Thank you!

Offline
  • 0

Users in this topic: 0 guests, 0 registered users

  • 1