From PunBB, we can convert:

  • bans

  • categories

  • censoring

  • config

  • forums

  • forum_perms

  • subscriptions

  • groups

  • online

  • posts

  • reports

  • search_cache

  • search_matches

  • search_words

  • topics

  • users

After Conversion

After running the standard convertor facility, you must also download the attached addons and plugins. These are for compatibility between passwords, and ensure once users login their passwords are converted into Panther's sha512 passwords with 16 characters of salt.

You must also download an additional addon which is attached, this is called 'fix_last_topic.php' and will run once, and automatically remove itself from your forum. This fixes the last topic information on the index page which was not previously there in PunBB.

From using the plugin, you can find out how many users' passwords still need to be upgraded on your forum. One they have all been upgraded, you can remove the plugins and addons from your forum.

Note: Without using the below plugin, you will be unable to login to your forum because the passwords cannot be converted without this procedure. This will convert PunBB md5/sha1+salt passwords from the 1.2, 1.3 & 1.4 branches. You will have to login twice in order for this to work.

Now, go to this topic, and download the addon 'fix_last_topic.php'. This will fix the last topic on the index page. You can also download the plugin 'AP_FluxBB_Password_Status.php' to see how many passwords still need to be converted on your forum.

Kind regards,
Christopher Marshall
chris [at] get-aura [dot] org

Project Manager